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2017.11 無店面產業論壇

時間
分
鐘 內容 講者

1 13:30~14:00 30 來賓報到

2 14:00~14:05 5 主辦單位致詞 無店面公會廖尚文理事長

3 14:05~14:10 5 頒發顧問聘書及大合照

4 14:10~14:50 40 科技立法，立法創新 立法院許毓仁立法委員

5 14:50~15:30 40 數位匯流環境下的法制革新 國家通訊傳播委員會詹婷怡主委

6 15:30~15:40 10 中場休息

7 15:40~16:20 40 行動支付在台灣的整合與實現
亞洲·矽谷計劃執行中心
謝穎青法制長
卓瑩鎗顧問

8 16:20~17:00 40 數位經濟時代下的隱私保護思維
國際通商法律事務所
余若凡合夥律師
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行動生活
萬物聯網

我國支付現況與金融科技發展

國發會亞洲矽谷計畫執行中心
法制長 謝穎青
特聘僱問卓瑩鎗

行動支付在台灣的整合
與實現

1



目前
曾任

• 國發會亞洲矽谷計畫

執行中心特聘僱問

• 群信行動數位科技

策略長
• 國立中正大學

電機工程系/通訊工程系
助理教授

• 悠遊卡公司

企劃室主管
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電子
支付

電子
票證

行動
支付

實施的成效與補漏 消保措施 該如何急起直追？
• 電子支付的成效
• 尚待補強的地方

• 無記名式電子票證
• 記名式電子票證
• 電子票證掛失問題

• 解決實名制問題
• 建構行動生活生態圈
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實施的成效與補漏

• 電子支付的成效

• 尚待補強的地方

電子
支付
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非現金支付服務說明電子支付的成效

備註：何謂第三方支付?
就是你跟我買東西，你先把錢放到給第三人，等到我給你的東西沒問題了，第三人再給我錢。

行動
支付

電子
支付

5家

電子
票證

4家

第三方
支付

5,535家2大系統

歐付寶、橘子支、
國際連、智付寶、
台灣支付

悠遊卡、一卡通、
iCash、HappyCash

LINE Pay、街口支付、
Pi錢包、Gomaji Pay、
Yahoo奇摩輕鬆付…

市場
樣態

HCE、TSM

功能
比較

可以儲值
不可轉帳

可以儲值
可以轉帳

不可儲值
不可轉帳

實體卡片轉虛擬
之技術系統
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歸納目前四大戰法電子支付的成效

下
往下綁

作業系統

( 要是
世界級大廠 )

後
往後綁

線上/線下商品圈

( 要有
很好的工商關係 )

垂直綁

行動生活圈

直

( 要有頂尖的
上下游垂直鏈技術 )

前
往前綁

發卡/收單銀行

( 要有
很好的政治關係 )

1. QR code統一規格

2. P2P轉帳

3. 收政府規費
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來自國際的競爭者尚待補強的地方

Q: 靠Gateway擋住了Apple pay、Samsung pay、Android pay，但我們能擋多久?

支付寶後面有阿里巴巴的淘寶、微信支付後面有騰訊QQ！

往下綁「作業系統」 往後綁「線上/線下商品圈」
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達到成功的四大曙光尚待補強的地方

稅負

稅負的誘因
極為重要

QR code

QR code技術
統合、解譯、清算、通路

(因為iOS NFC未開放)

電子
發票

電子發票
與獎金的議題

收單

收單方的
劃時代革新
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的消保措施

• 無記名式電子票證

• 記名式電子票證

• 電子票證掛失問題

電子
票證
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無記名式電子票證

無記名式電子票證如有滅失、遺失或被竊等情形時，持卡

人不得掛失止付。

參照公益彩券發行條例第十一條第三項：「公益彩券遺失、

被盜或滅失者，不得掛失止付」，於第一款規定無記名式

電子票證不得掛失止付。

不可掛失

參照條文
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記名式電子票證

記名式電子票證如有遺失或被竊等情形時，持卡人應儘速以電話

或其他方式通知發行機構或其他經發行機構指定機構辦理掛失停

用手續，並繳交掛失手續費。

記名式電子票證持卡人依前款規定以電話或其他方式通知掛失，

即視為完成掛失手續；並自完成掛失手續後被冒用所發生之損失，

應由發行機構負擔。

但依前款完成掛失手續後N小時內，就非線上即時交易被冒用所

發生之損失，應由持卡人自行負擔。

掛失方式

風險承擔
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電子票證掛失議題

捷運
閘道門

公部門
結構

從捷運閘道門來看
記名電子票證掛失

從公部門結構面來看
記名電子票證掛失
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該如何急起直追？

• 解決實名制問題

• 建構行動生活生態圈

行動
支付
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實名制
如何解決問題

解決實名制問題
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Mobile Connect 說明

GSM
協會建置

多國
應用

電信
服務

• 由國際GSM協會（Groupe Speciale Mobile Association，GSMA）

於1995年成立，是一個為了GSM行動電話系統的共通

標準、建置以及推動，由行動通訊業者以及相關公司所

贊助成立的協會。

• GSMA由220多國，近800家的「行動業者」組成，其也讓200多

家業者構建了行動生態體系，包含手持式製造商、軟體公司、裝

置提供商、網際網路業者、媒體與娛樂業者等等。

「一個全球具有最高權力的貿易協會，其可從稅務

政策到價格制定策略皆可對各政府進行遊說。」

解決實名制問題
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為什麼實名制
跟電信服務有關係

軟體
服務面

硬體
晶片面

解決實名制問題
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Mobile Connect 技術說明

台灣五大電信

商務服務
提供單位

提供消費者
相關服務

政府單位

民間企業

金融機構

交通中心

電子票券

購物平台

社群論壇

使用者

手機
號碼

簡化
註冊、登入

流程

取代
臨櫃申請
流程

跨平台
帳號整合

網路
交易、付費

認證

內部系統
登入認證

Mobile Connect

平台

GSMA

解決實名制問題
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如何建構
行動生活生態圈

建構行動生活生態圈
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習慣改變建構行動生活生態圈

數位
鑰匙

行動
錢包

19



數位
門票

支付
資安工具

網路電商支付工具
QR code大串聯

數位
鑰匙

• 停車場閘道門
• 家庭辦公環境控管
• 萬物聯網資訊控管
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萬物
聯網
IoE

IoE萬物聯網
(Internet of Everything)

包含了四個重要要素，分別是

人、流程、數據、事物對象
21

IoT物聯網
(Internet of Things)

物聯網
IoT

行動生活
萬物聯網



行動生活
萬物聯網

我國支付現況與金融科技發展

國發會亞洲矽谷計畫執行中心

行動支付在台灣的整合
與實現
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國發會亞洲矽谷計畫執行中心

致力建構一個行動生活生態圈
來提升台灣的行動支付
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數位經濟時代的隱私保護思維 
 

 

 
國際通商法律事務所余若凡合夥律師 

 

 



 

“There are only two types of companies, those that have 

been hacked and those that will be.”  

        (Robert Mueller, Director, FBI, March, 2012) 

 

 

 

 

 

 

 



“The technical level of cyber attacks is growing 

exponentially. What was considered a sophisticated cyber 

attack only a year ago might now be incorporated into a 

downloadable and easy to deploy internet application, 

requiring little or no expertise to use.” 

          (Iain Lobban, Director of UK’s GCHQ, 2012) 
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‒Uber (2016) 
▪ Data of 57 million Uber users and drivers in 2016. 

▪ The company paid hackers $100,000 to delete the data and keep the breach 

quiet, and did not report the breach. 

‒Yahoo! (Dec 2013 and 2014) 
▪ 2014 breach: over 500 million Yahoo! user accounts affected. 

▪ 2013 breach: over 1 billion user accounts affected.  

▪ More  than 3 billion of its user accounts were impacted. 

 

 

 

全球大量資料外洩事件 
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‒南韓 (Jan 2014) 
▪ Credit Card information of 20 million people stolen 

 

‒新加坡 (Dec 2013) 
▪ Credit card statement processor for bank hacked 

▪ Confidential information of 647 private wealth clients stolen 

 

 

 

亞太地區大量資料外洩事件 
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Update on Data Protection Law in Hong Kong  
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亞太區域個人資料隱私保護之
趨勢 
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‒ 在現行法制中，加強對個人資料及隱私的保護 
 
‒ 增訂新個人資料或隱私的法規 

 

‒ 增加對於個人資料保護議題的關注，尤其是對於個人資
料外洩之情況 
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Thailand: Draft law 

sent to Parliament in 

2012 and passed in 

2015 (in principle) 

Taiwan: PDPA 2010 in 

effect from 1 October 

2012 

Singapore: PDPA  

passed 15 October 

2012; phase-in 

period until 2/1/14 

and 2/7/14 

China: Provisions 

regulating Internet 

Information Services/ 

NPC Decision on 

strengthening the 

protection of internet 

information  

Hong Kong: Personal 

Data (Privacy) 

Amendment Ordinance 

(amendments in full 

effect on 1/4/2013)  

South Korea: 
Personal Information 

Protection Act 2011 

Philippines:  
Data Privacy Act 

(August 2012) 

Cybercrime Prevention 

Act (September 2012) 

Malaysia: PDPA 2010 in 

effect from 15 November 2013 

Australia:  
Privacy Amendments 

Enhancing Privacy 

Protection Act come 

into effect  in March 

2014 

India: The Information 

Technology (Reasonable 

Security Practices and 

Procedures and 

Sensitive Personal Data 

or Information) Rules, 

2011 

Vietnam: Provisions spread 

across the Civil Code, the IT Law, 

the Penal Code and the 

Telecommunications Law and 

their implementing regulations. 

Law on Cyber Information Security 

was passed in 2015 and effective 

from 2016.l  

 

Japan Act on the 

Protection of Personal 

Information 2003 

Indonesia:  
Electronic Information and 

Transaction Law 2008; 

Regulation 82 Provision of 

Electronic System and 

Transaction; Personal Data 

Protection in Electronic 

Systems issued in 2016 

亞太地區 
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資料外洩之通知義務  
Australia China Hong 

Kong 

India Indonesia Japan Malaysia Philippines Singapore South 

Korea 

Taiwan Thailand Vietnam 

Statutory obligation to 

notify data subject  ✓5 ✓ ✓ ✓ ✓  (✓) 

Statutory obligation to 

notify regulator ✓ ✓5  (✓) ✓ 

Sector specific 

obligation to notify ✓6 ✓  

 
✓2 

(New 

Cyberse

curity Bill 

draft)   

✓3 ✓ 

Non-binding 

Guidelines ✓ ✓  

 
✓1 ✓  

 
✓4 

1  Sector specific guidelines for financial services and banking industries create strong incentive to notify government authorities 

2  Monetary Authority of Singapore regulations require notification; new Cybersecurity Bill requires notificaion by CII.   

3 Telecommunications Business Act relating to subscriber‘s right 

4   Credit Information Protection Committee 

5   For large scale breaches 

6   ICPs and telecoms operators 
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罰則  
Australia  Civil and criminal penalties range from AU$340,000 for individuals or AU$1.7 million for corporations 

China  Civil liability for infringement of individual rights; administrative penalties, fines of up to RMB500,000 and up to 10 times illegal 

income for Consumer Protection Law; fines of up to RMB30,000 under other laws 

HK Civil and criminal penalties up to HK1 million for personal data for direct marketing + 5 years imprisonment 

Indonesia No sanctions under EIT law and Regulation 82 

India  Damages for breach of IT Act.  No limit on amount recoverable 

Japan Statutory penalty – imprisonment up to 3 years and/or fine up to JPY500,000 

Malaysia  Up to RM500,000 fine and/or imprisonment of up to 3 years 

Philippines  Up to Php1,000,000 + imprisonment of up to 5 years 

Singapore  Civil fines up to $1million; Criminal max fine of S100,000 and/or imprisonment of up 12 months for obstruction or making of false 

statements to mislead. 

Korea Fine up to KRW 50 million / imprisonment for up to 5 years 

Taiwan  Up to NT200,000 

Thailand Fine of suspension / revocation of telecoms licence  

Criminal penalties under Credit Bureau Act + draft Privacy law 

Vietnam Fine up to VNP20,000,000 
      

10 



中國 
 

Development Status Practical Impact 

個人資料保護法 Draft since 2005 – Uncertain what it will cover and when it will be promulgated 

– New draft rules January 2012 

中华人民共和国刑法
修正案 

Effective from 28 

February 2009 

– Criminal offence for anyone in Government to sell or receive personal 

information in course of work 

中华人民共和国侵权责

任法 

 

Passed December 

2009 

Effective from 1 July 

2010 

– Formally recognised privacy rights as a form of civil rights and  interests 

中华人民共和国社会
保险法 

Effective from 1 July 

2011 

– Protects confidentiality of personal social insurance information 



Name Status Practical Impact 

中華人民共和國居民身份
證法 

Passed October 

2011 

– Strengthened protection of personal data recorded on identity cards 

江蘇信息相關規範 Effective from 1 

January 2012 

– restrictions on the collection and use of personal information in Jiangsu 

Province 

– first province to implement regulations not limited to a particular 

industry 

全國人大常委會關于加強

網絡信息保護的決定 
 

Passed 28 

December 2012 

– Offers state protection to electronic information that identifies an 

individual and/or relates to the individual’s privacy 

– imposes obligations on organizations that collect and use such 

personal electronic information in their business operations  

 



Name Status Practical Impact 

中华人民共和国广告法  September 1, 

2015 

 

– Introduces certain provisions addressing data privacy issues.  

– a fine of between RMB 5,000 to RMB 30,000. 

 

中华人民共和国刑法修正
案 

August/Novembe

r 2015 
– a much wider scope of application 

 

中华人民共和国网络安全
法 

November 2016/ 

June 2017 
– China’s first law specifically regulating activities in cyberspace 
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Update on Data Protection Law in Hong Kong  

      14       14 

全球個人資料隱私保護之趨勢 



15 

 

 歐盟一般資料保護法規(GDPR) 

• New, stricter standards for data protection 

• Extra-territorial scope — if EU citizens’ 

data  is involved, assume GDPR applies 

• Penalties up – EUR 20 million or 4% 

annual global turnover  

• Breach notification 
Consent + transparency requirements 

Planning, documentation and accountability 

requirements 

Direct obligations on data processors 

Data Protection Officer? 

Key changes 
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ePrivacy 

GDPR = personal data 

ePrivacy = electronic communications and 

information + direct marketing 

GDPR is the floor, e-Privacy would trump 

“Intercept” jurisdiction extended globally and to  

OTT and M2M players 
Cookies preferences by browser settings (opt in)   

No consent required for first party analytics 
Direct marketing soft opt in still possible, but  

GDPR grade consent 

ePrivacy 

Reg 

[proposal] 

Version 1 
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Update on Data Protection Law in Hong Kong  

      17       17 

台灣個人資料隱私保護之趨勢 
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‒ 現行個資法的討論 
▪ 設立個人資料保護專責機關？ 
▪ 資料在地化？ 

 
‒ 資通安全管理法草案 

▪ 關鍵基礎設施提供者的範圍？ 
▪ 關鍵基礎設施提供者的義務及政府稽查的權利？ 
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All once update has been made 

Update on Data Protection Law in Hong Kong  

      19       19 

個人資料及隱私保護 
   -  從法律遵循到競爭力 



資安風險影響： 

 
– 股價 
– 公司價值 
– 併購可能性 
– 公司品牌及聲譽 
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公司需要關心的是：  

✓盤點所有重要個資資產及評估可能面臨資安的風險？ 

✓確認及妥適分配維護資安的責任？ 

✓完成公司內部資安政策？ 

✓完成緊急資安事件的應變程序？ 

✓管理階層是否已經開始重視資安風險並支持相關資安政策？ 

✓定期的員工訓練？ 

✓完成保險？ 

 



公司更需要關心的是： 

 
– 公司文化 

 

– 公司的 IT環境 

 

– 公司人員素質及資安意識 
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INSTRUCTIONS 
How to apply a Slide Layout 

Go to the Home tab and select   

New Slide to choose from a  

variety of formatted B&M slide layouts 

Tip: choose Layout to reapply a layout to a 

selected slide(s) 

How to apply slide text styles 

Use the Decrease List Level and Increase 

List Level icons on the Home tab to apply 

the required text style 

Tip: use the Reset option from  

the Home tab to restore template text styles 

to a slide 

How to update footer and slide numbers 

Go to the Insert tab and select 

Header & Footer. Select Apply to 

All once update has been made 

Update on Data Protection Law in Hong Kong  
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若是資料外洩仍發生…? 
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INSTRUCTIONS 
How to apply a Slide Layout 

Go to the Home tab and select   

New Slide to choose from a  

variety of formatted B&M slide layouts 

Tip: choose Layout to reapply a layout to a 

selected slide(s) 

How to apply slide text styles 

Use the Decrease List Level and Increase 

List Level icons on the Home tab to apply 

the required text style 

Tip: use the Reset option from  

the Home tab to restore template text styles 

to a slide 

How to update footer and slide numbers 

Go to the Insert tab and select 

Header & Footer. Select Apply to 

All once update has been made 

‒財務風險 

▪ 智慧財產權的喪失 

▪ 業務中斷 

▪ 勒索 

▪ 對他人的賠償責任 

‒商譽損失  

▪ 消費者信心消失  

▪ 媒體大幅報導 

‒資料遭竊或是個人資料遭竊 

‒資安漏洞 

 

風險  

24 



©  2014 Baker & McKenzie 

INSTRUCTIONS 
How to apply a Slide Layout 

Go to the Home tab and select   

New Slide to choose from a  

variety of formatted B&M slide layouts 

Tip: choose Layout to reapply a layout to a 

selected slide(s) 

How to apply slide text styles 

Use the Decrease List Level and Increase 

List Level icons on the Home tab to apply 

the required text style 

Tip: use the Reset option from  

the Home tab to restore template text styles 

to a slide 

How to update footer and slide numbers 

Go to the Insert tab and select 

Header & Footer. Select Apply to 

All once update has been made 

商業及營運的風險  

 

‒資安和系統薄弱 - 補強漏洞  

‒緊急資安事件應變計劃的測試 

‒IT設備應急和備份計劃 

‒通報保險公司 

‒通報被害人及主管機關(?) 

▪ 是否通報？何時通報？揭露多少？ 

 

 

 

25 



©  2014 Baker & McKenzie 

INSTRUCTIONS 
How to apply a Slide Layout 

Go to the Home tab and select   

New Slide to choose from a  

variety of formatted B&M slide layouts 

Tip: choose Layout to reapply a layout to a 

selected slide(s) 

How to apply slide text styles 

Use the Decrease List Level and Increase 

List Level icons on the Home tab to apply 

the required text style 

Tip: use the Reset option from  

the Home tab to restore template text styles 

to a slide 

How to update footer and slide numbers 

Go to the Insert tab and select 

Header & Footer. Select Apply to 

All once update has been made 

 

‒行政處罰 
 

‒民事訴訟 

 
其他考量： 
‒是否對侵入者提起訴訟？民事？刑事？如何提？ 
‒是否對職員或顧客等提起訴訟？ 

 

 

法律的風險 
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– 資料及證據保存 

– 雇用緊急資安事件的專業人士或公司 

– 蒐集資訊 

▪ 攻擊的性質 

▪ 遭影響的資料或系統 

▪ 受影響的人數 

▪ 入侵者為何人 

▪ 資訊安全的疏漏及補救之道 

– 外部律師的角色 

 

內部調查 
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INSTRUCTIONS 
How to apply a Slide Layout 

Go to the Home tab and select   

New Slide to choose from a  

variety of formatted B&M slide layouts 

Tip: choose Layout to reapply a layout to a 

selected slide(s) 

How to apply slide text styles 

Use the Decrease List Level and Increase 

List Level icons on the Home tab to apply 

the required text style 

Tip: use the Reset option from  

the Home tab to restore template text styles 

to a slide 

How to update footer and slide numbers 

Go to the Insert tab and select 

Header & Footer. Select Apply to 

All once update has been made 

務實的考量點 

 

‒值得追訴？ 
 

▪ 侵入者的匿名性？ 

▪ 侵入者位於國外？ 

▪ 侵入者有能力賠償？ 

▪ 所花費的時間及成本 

▪ 自己反而被追訴的可能性？ 

▪ 媒體報導的可能性？ 
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INSTRUCTIONS 
How to apply a Slide Layout 

Go to the Home tab and select   

New Slide to choose from a  

variety of formatted B&M slide layouts 

Tip: choose Layout to reapply a layout to a 

selected slide(s) 

How to apply slide text styles 

Use the Decrease List Level and Increase 

List Level icons on the Home tab to apply 

the required text style 

Tip: use the Reset option from  

the Home tab to restore template text styles 

to a slide 

How to update footer and slide numbers 

Go to the Insert tab and select 

Header & Footer. Select Apply to 

All once update has been made 

Thank You 

余若凡律師 
國際通商法律事務所合夥律師  

+886 2 27157268 

jo-fan.yu@bakermckenzie.com 
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加入無店面公會

※官網：
www.cnra.org.tw

※FB粉絲團：
www.facebook.com/cnra.org

2


	投影片編號 1
	緣起 (1/2)
	緣起 (2/2)
	公會任務
	組織架構
	會員資格說明
	會員資格說明
	會員資料分析
	2014-2017會員數成長分析
	第2屆理事長及常務理監事名單
	第2屆理監事名單
	會員名單
	會員名單
	會員名單
	會員名單
	會員名單
	2014~2017公會組團紀錄表(1/3)
	2014~2017公會組團紀錄表(2/3)
	2014~2017公會組團紀錄表(3/3)
	公會電商人才培育課程（1/2）
	公會電商人才培育課程（2/2）
	投影片編號 22

